Back to overview
Resolved

File downloads unavailable

Aug 10, 2026 at 2:03pm UTC
Affected services
public.govinity.com
secure.govinity.com

Resolved
Aug 10, 2026 at 3:25pm UTC

From approx 7:00 AM to 8:15 AM PDT, file downloads were unavailable due to an issue with an upgrade to our cloud file signing service. That issue was resolved and file downloads have returned to full availability.

Created
Aug 10, 2026 at 2:03pm UTC

File downloads are unavailable. Issue has been escalated and team is investigating.